Skip to content
Tags

,

testing the value of a string for a list of values

July 17, 2012

when testing for values of a string, i do not like doing something like

[“apple”, “orange”, “banana”].include? my_fruit

i would rather do

my_fruit == /apple|orange|banana/

The advantage is readability. The former tends to confuse the reader, in my opinion

Advertisements

From → Uncategorized

Leave a Comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: